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COMMON HALF YEARLY EXAMINATION – DECEMBER 2018 

Standard – 12 (kancheepuram) 

Computer Science – Answer Key 

Section – I 

 

 

 Choose the correct answer :                                                                                                5 X 1 = 15  

1. d) Ctrl + A  

2. d) Fajita  

3. d) MM/DD/YY  

4. b) SUM( )  

5. c) 5  

6. a) 20  

7. a) Joint Photographic Experts Group  

8. c) 15  

9. a) { }  

10. c) 15  

11. b) 29  

12. a) 1  

13. c) ~  

14. a) Computer Based Tutorials  

15. c) 3  

 II. Answer any six questions : ( Questions No.22 is compulsory)                             6 X 2 = 12  

16. Text Editing :  

Entering a new text or modifying the existing text in a document is known as Text  

Editing.  

17. Types of paragraph Alignment :  

Centered Ctrl+E  

Left-aligned Ctrl+L  

Right-aligned Ctrl+R  

Justified Ctrl+J  

18. Auto Correct options :  

StarOffice Writer recognizes some common misspellings and typographical mistakes and makes the 

replacement automatically.  

Ex : “ The “ is automatically changed into “ The ”.  

19. Popular Spreadsheet software :  

 Excel - Microsoft Corporation  

 Quattro Pro - Borland International.  

 Improve - Lotus Corporation  

 StarOffice Calc - Sun Microsystems.  

20. Difference between Query and Filter :  

 The difference between query  and filters is that queries can be saved for later use  

 Filter cannot be saved later use  
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21.what is compression ? 

Compression is a technique by which a recurring set of information is identified and replaced by a single 

piece of information.  

 There are two compressions 

1.Loss less        2.Lossy 

22.Expression using conditional operator 

f = ( x==30) ? 0.5:5  

23.Different types of inheritance  

There are different types of inheritance. 

1. Single inheritance 

2. Multiple inheritance 

3. Multilevel inheritance 

4. Hybrid inheritance 

5. Hierarchical inheritance 

24.Use of call centers  

 A call center has adequate telecom facilities, trained consultants, access to wide 

database, Internet and other on-line information support to provide information and 

support services to customers. 

 It operates to provide round the clock and year round service ie, 24 xn365 service 

III. Answer any six questions : ( Questions No.32 is compulsory)                             6 X 3 = 18  

25. Change the rows and column width 

 To resize a column, place the cursor in a table cell, hold down Alt, and then press  

the left or the right arrow.  

To resize the column without changing the width of the Table, hold down Alt+Ctrl, and then press the left 

or the right arrows.  

 To resize a row, place the cursor in the row, hold down Alt, and then press the up  

or the down arrows.  

 Table → Table Properties command is used .  

 Table Format dialog box appears.  

 Choose the Columns tab .Type column size in the Column Width spin boxes and click OK 

button.  

26.How will you insert page numbers in footer? 

Click on Insert → Fields → Page Number will insert page numbers on every page. 

Normal text can also be included in the header and footer. 

27.what is Range ? give Example 

 A continuous group of cells in a worksheet is called a Range. A range is referred to by therange 

address.For example: the cells, G1, G2, G3, G4 and G5 can be called G1:G5. 

28.Reference Operators 

These operators combine areas. 

Operator                   Name                   Example 

: (Colon)                Range                   A1:C108 

!(Exclamation point)  Intersection   SUM (A1:B6!B5:C12) 

29.what is report? Types of reports  

A report is printed information that is assembled by gathering data based on user supplied 

criteria. 

 Static report 

 Dynamic report 
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30.What is meant by “Rehearse Timings”? 

 Star office assists in defining the right rehearse timings for automatic slide changes. Star Office 

records the display time for each slide. 

 The next time you play the show with automatic slide changes, the timing will be recorded. 

31.Define Encapsulation? 

The binding of data and functions together into single entity is referred to as 

encapsulation. 

32.Error snippets 

switch(x) 

 {  

case 1 to 2: 

cout<<”one”<<”Two; break; 

 }  
33.What is called theft of “Computer time”? 

 Most of the computers in an organization have lot of free computer time to spare. In other 

words a lot of computer time is not used. Many solutions for using this spare time are being 

researched.  

 However, this idle time of computers in an organization is being stolen illegally. 

Some other software runs on an idle computer without the knowledge of the organization.  

 This iscalled theft of ‘computer time’. 

IV.Answer all questions :                     5*5=25        

34. Find & Replace 

1. Choose Edit → Find & Replace or Ctrl + F The Find & Replace dialog box appears as shown 

in the Figure. 

2. In the Search for box, type the text that you want to find in your document. 

3. In the Replace with box, enter the replacement word or phrase. 

4. Click Find to start the search. 

5. When Writer finds the first instance of the word or phrase, do one of the following: 

 To replace the found instance of the text with what you entered in the Replace with box, 

click Replace. 

 To replace all instances of the text with what you entered in the Replace with box, click 

Replace All. 

 To skip the found text and to continue the search, click Find again. 

6. Click Close when you have finished the search.  

 
 

(OR) 
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How would you carry out the spell check after the entire document is typed? 

Checking the Spelling after the Document is Typed 

The following steps are used for a spell check. 

Tools → Spelling → Check is selected or is clicked. To check a part of the document 

only that portion is selected. The F7 key may also be pressed to select the spelling command. 

Not in dictionary text area displays the misspelled word and the Suggestions list displays any 

alternative spellings. Any of the following can be done: 

 To skip this occurrence but stop on the next one. Ignore Once button is clicked. To skip 

all occurrences of this word. Ignore All button is clicked. 

 To replace the word with one of the selected spellings, in the suggestions list that spelling 

is clicked, and Change button is clicked. 

 To change this occurrence to Change All button is clicked to replace all occurrences of 

the word. 

 If none of the replacements is correct, correction can be made manually in the Not in 

dictionary text area. 

 Add button is clicked to add the word to the dictionary. 

 
 

35.What are the Various function of the icons in the table formatting tool bar? 

 
 Table Fixed 

Fixed, Proportional 

Table, Variable 

 Merge Cells - This icon is used to combine two or more cell into a single cell. 

 Split Cells - This icon is used to split a cell into two or more cells. 

 Optimise - Clicking on this icon displays a pop up menu with options like Space columns 

equally, Space rows equally, Optimum row height and Optimum column width. 

 Inserting Row - This icon is used to insert a row below the current row. 

 Inserting Column - This icon inserts a column to the right of the current column. 

 Delete Row - This icon deletes the current row from the table. 

 Delete Column - This icon deletes the current Column from the table. 

 Borders - This icon displays a floating toolbar with different border option for 

the table. 

 Line Style - This icon is used to choose the style of line to be used for the border. 

 Border Colour - Clicking on this icon displays a palette of colours that can be 

used as a border colour for the table. 
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(OR) 

 

How will you insert chart in a Work sheet. 

1. Right click any of a sheet tab in the workbook. 

2. And then choose the option “Insert” in the menu. 

3. Next you will see the “Insert” window. Here choose the option “Chart” in the window. 

4. And then click “OK”. 

Select the data you want to chart. 

 Click on Insert → Chart or click on the Insert Chart icon as discussed earlier. 

 The cursor becomes a + sign with a small picture of the graph. Place this cursor where you 

want to insert the chart and click. 

 It prompts you to enter the area in the worksheet to be charted. Enter the range as C3 : F7 

and click Next. 

 The next window, which appears as shown in figure 6.31 displays the different types of 

charts that can be created along with a preview of each. Select the type of chart in which 

you want to present the data. The preview. Window shows the chart. Click on Next. 

 For each type of the chart (say Pie, Bar, Column, etc.), there are different formats 

available. These formats are displayed in the next window a preview of the each format is 

also displayed. Here, select the desired format. Click on Next. 

 In the next window ,you have provisions to give a Title for the chart, Titles for X and Y 

axes and legends. 

 
 Click on Create. Now, your worksheet will created. 

 

36.Explain different Database types 

1. Flat – File database 

2. Relational database 

3. Hierarchical database 

4. Network database 

5. Object-Oriented database 

Flat – File Database 

A database file that consists of a single data table is a Flat-file database. Flat-file 

database can be quite useful for certain single user or small-group situations, especially for 

maintaining lists such as address lists or inventories. Data that is stored, managed, and 

manipulated in spreadsheet is another example of a flat-file database 

Relational database 

A relational structure represents a database made up of a set of related tables. In a 

relational database, one or more common fields existing in two or more tables create a 

relationship between these tables. The common field or fields are called the Keys. 

A primary key is a key that uniquely identifies a record in a database table. In relational 

databases, a primary key can consist of one or more fields. 
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Hierarchical database 

The hierarchical database structures were primarily used on Main Frame computers. In 

hierarchical databases, records are organized in a tree like structure by type. The relationship 

between record types is said to be a parent-child relationship, in which any child type relates only 

to a single parent type. 

Network database 

The Network database is very similar to the hierarchical structure except that any one 

record type can relate to any number of other record types. 

Object oriented database 

The object oriented structure groups data items and their associated characteristics, 

attributes, and procedures into complex items called objects. 

An object is defined by its characteristics, attributes and procedures. An object’s 

characteristics can be text, sound, graphics, and video. Examples of attributes might be colour, 

size, style, quantity, and price. 

(OR) 

37.Explain the different types of scopes variables in C++? 

There are four types of scopes in C++. They are 

1. Local scope 2. Function scope 3. File scope 4. Class scope 

1. Local scope: - 

 It is defined within a block 

 It is the block in which it is defined. 

 It cannot be accessed from outside the block of its declaration. 

 A block of code begins and ends with curly braces { }. 

 It exists only while the block of code in which they are declared is executing 

2. Function scope: - 

 It is declared within a function is extended to function block, and all sub-blocks. 

 It is accessible in all the sub-blocks. 

 The lifetime of a function scope variable is the lifetime of the function block. 

 The scope of formal parameters is block function scope. 

3. File scope: - 

 A variable declared above all blocks and functions have the scope of a file. 

 The file scope variable is the entire program. 

 The lifetime of a file scope variable is the lifetime of a program. 

4. Class scope: - 

 A Class is a way to bind the data and its associated functions together. 

 Classes provide a method for packing together. 

37.Explain the ‘Nested.. if’ statement with an example in C++? 

The statement sequence of if or else may contain another if statement 

ie., the if else statements can be nested within one another. 

Syntax:- 
if (expression -1) 

if (expression -2) 
{ 

action -1; 

} 
else 

{ 

action-2; 
} 

else 

{ 
action-3; 

}; 

Example:- 
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if (grade = = ‘A’) 

if (basic > 5500) 

incentive = basic * 10/100; 

else 

incentive = basic * 5/100; 

else 

cout << “Try to attain Grade A”; 

Working of the above example : 

 Grade = ‘A’ and basic == 5501, then incentive gets the value 550. 

 Grade = ‘A’ and basic = = 5000, then incentive gets the value 250. 

(OR) 

List out the rules for overloading operators?  

 Only existing operators can be overloaded. New operators cannot 

be created. 

 The overloaded operator must have at least one operand of userdefined 

type. 

 The basic definition of an operator cannot be replaced. 

 Overloaded operators behave in the same way as the basic 

operators in terms of their operands. 

 When binary operators are overloaded, the left hand object must 

be an object of the relevant class 

 Binary operators overloaded through a member function take one 

explicit argument. 

38.Find the output of the following program : 

Ans: 

HELLO  

Values of A and B  

The two integers are 10 20  

The sum is 30  

The multiply is 200  

(OR) 

 

Debug the folloeing program : 

 
Line No  Incorrect code  Correct code  

1  #include<iostram.h>  #include<conio.h>  

2  include<coino.h>  #include<conio.h>  

5  Private;  private:  

7  Public:  public:  

9  PROTECT:  protected:  

12  class A ; Public B;  class B : public A  

14  Public:  public:  

17  int b1:b2:b3  int b1, b2, b3;  

18  b1=a1  a1 is a private member 

which cannot be 

accessed outside the 

class  

Inbetween 20 & 21  } statement missing  

22  void( )  void main( )  

25  der:a3;  der.a3=0;  

26  a3:fun( );  der.func( );  
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