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ANSWER
d)ctrl+A
d)fajitha
d)MM/DD/YY
b)SUM()
c)5
a)20
a)Joint photographic experts group
c)15
A{}
c)15
b)29
a)1
c)~
a)computer based tutorial
c)3
Section-II
1.Entering a new text or modifying the existing text in a document is
known as text editing.
2.Copy , cut , paste , find and replace are some of the commonly used
editing functions.
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1. Left alignment Ctrl + L
2. Right alignment
Ctrl + R
3. Center alignmentCtrl + E
4. Justify alignment Ctrl + J

1
1

2

1.Star office Writer will automatically correct some spelling istakes.
Star office writer recognizes some common misspellings and
typographical mistakes and makes the replacement automatically
using autocorrect option.
2. Eg. If a word is typed as ‘teh’ staroffice writer automatically
replaces this with the correct word ‘the’ .
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MARKS
15X1=5

1

1
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Packages

Developers

VisiCalc

Dan bricklin and bon frankston

Lotus 1-2-3

Lotus development corporation

Excel

Microsoft corporation

Quattro pro

Borland International

Improve

Lotus corporation

Star office calc

Sun micro systems

Query

Filter

Query can be saved later use

Filter cannot be saved later use

2

20

21

2

1.Compression is a technique by which a recurring set of information 1
is identified and replaced by a single piece of information.

22.
23.

1

1. Lossless compression :
2.Lossy compression :
(x=30)?f=0.5:f=5

2

 Single inheritance,
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 Multiple inheritance,

 Multilevel inheritance,

2

 Hybrid inheritance and
 Hierarchical inheritance.
24

1).A call center is sometimes defined as a telephone based shared
service center for specific customer activities and are used for
number of customer-related functions like marketing, selling,
information transfer, advice, technical support and so on.
2).A call center has adequate telecom facilities, trained consultants,
access to wide
database, Internet and other on-line information support to provide
information and
support services to customers.
3).It operates to provide round the clock and year round service
i.e.24 x 365 service.
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SECTION-III
25

26

The selected rows and columns are made same size by using the
following steps :
1)To resize the column width, place the cursor in a table cell, hold
down the Alt, and then press left or the right arrow. To resize the
column without changing the width of the table, hold down the
Ctrl + Alt, and then, press the left or the right arrows.
2).To resize the row height, place the cursor in a table row, hold
down the Alt, and Then press up or the down arrows.
3)TableTable properties

1

1

1

1. Click in the footer area.
2. Click on Insert  Fields. A sub menu with a list of options
appears. Clicking on

1

an option in the list will insert the appropriate text in all the pages.
For example:
clicking on Insert  Fields  Page Number will insert page
numbers on every page . Normal text can also be included in the
header and footer. To do so, simply type the text where we want it.
27

28

29.

30
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1)A continuous group of cells are called range.A Range is refered by
the range address.
2) A Range address is the address of the first cell in the range,
followed by a colon ,
followed by the address of the last cell in the range.
Example:
The cells G1,G2,G3,G4 and G5 can be called G1:G5.
The cells A1,B1,C1,D1,E1 and F1 can be called A1 : F1
These operator combine areas
:(Colon)
=A1:A2
!(Exclamanation)
=SUM(A1:A2!B3:B5)
1)A report is printed information that is assembled by gathering
data based on user supplied criteria. Reports can range from simple
list of records to customized formats for specific perpose.
2)purposes. Static and dynamic are the two types of reports.
StarOffice assists in defining the right rehearse timings for
automatic slide changes.StarOffice records the display time for
each slide , so the next time you play the show with automatic
slide changes the timing will be as recorded.
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34
(Or)

1)The mechanism by which the data and functions are bound
together with in an object definition is called as encapsulation.
2)The process of grouping data and its related functions into units, 3
called as objects which paves way for
encapsulation.
Find any Three Error:
switch(x)
3
{
case 1 to 2:
cout<<”one”<<”Two”;
break;
}
1)Most of the computers in an organization have lot of free computer
time to spare. In other words a lot of computer time is not used.
This idle time of computers in an organization is being stolen
3
illegally. When computers in an organization are idle, Some other
software runs on these idle computer without the knowledge of
the organization. This is called theft of “computer time”.
SECTION-III
1)Choose Edit
→Find
&Replace.
2)In the Search for box, type the text that you want to find in your
document.
Find and Replace Dialog Box
3. In the replace with box, enter the replacement word or phrase.
4. Click Find to start the search.
5.When Writer finds
the first instance of
the word or phrase,
do one of the following:
• To replace the found instance of the text with what you entered in the
Replace with box, click replace.
• To replace all instances of the text with what you entered in the
Replace with box, click replace All.
• To skip the found text and to continue the search, click Find again.
6. Click Close
when you have finished the
search.
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1)Tools
→Spell
→Check is selected or
is clicked. To
check a part of the document only that portion is selected. The F7 key
may also be pressed to select the spelling command.
2)not in dictionary text area displays the misspelled word and the
Suggestions list displays any alternative spellings.
Any of the following can be done:
• To skip this occurrence but stop on the next one. ignore once
button is clicked.

1

1

1
1
1

2

1

1

 To skip all occurrences of this word. ignore All button is clicked.
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 To replace the word with one of the selected spellings, in the
suggestions list that spelling is clicked, and Change button is clicked
to change this occurrence and Change All button is clicked to replace
all occurrences of the word.
• If none of the replacements is correct, correction can be made
manually in the not in dictionary text area. Add button is clicked to
add the word to the dictionary.
Explain any 10 icon:

1
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(OR)

1)One of the most popular features of
StarOffice Calc
software is 1
the ability
to generate charts based on numeric data. The
purpose of chart is to visually present the data for easy understanding.
2)To draw a chart, follow the procedure given below:
• Select the data you want to chart.
• Click on Insert→Chart or click on the insert Chart icon as
1
discussed earlier.
• The cursor becomes a + sign with a small picture of the graph.Place
this cursor where you want to insert the chart and clickIt prompts
you to enter the area in the worksheet to be charted. Enter the range as
C3 : F7 and click Next.
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 The next window displays the different types of charts
that can be created along with a preview of each. Select the type of
chart in which you want to present the data. The preview Window
shows the chart.
 Click on Next.
 For each type of the chart (say Pie, Bar, Column, etc.), there are
different formats available .These formats are displayed in the
next window a preview of the each format is also displayed.
Here, select the desired format.
 Click on Next .In the
next window you have provisions to
give A Title for the chart, Titles for X and Y axes and legends.
 Click on Create
1. Flat – File database
2. Relational database
3. Hierarchical database
4. Network database
5.Object-Oriented database
Flat–File Database:
1)A database file that consists
of a single data table is a Flat-file
database. Flat-file database can be quite useful for certain single user or
small-group situations, especially for maintaining lists such as address
lists or inventories. Data that is stored, managed, and manipulated
In spreadsheet is another example of a flat-filedatabase. The
relational database structure is the most prevalent database in today’s
business organizations.
2)relational database:
A relational structure represents a database made up of a set of related
tables. In a relational database, one or
more common
fields existing in two or
more tablescreate a relationship between
these tables. The common field or fields are called the Keys.
3)Hierarchical database :
The hierarchical database structures were primarily used on Main
Frame computers. In hierarchical databases, records are organized in a
tree like structure by type. The relationship between record types is said
to be a parent-child relationship, in which any child type relates only to a
single parent type.
4) network database
The Network database is very similar to the hierarchical structure
except that any one record type can relate to any number of other record
types.
5) object oriented database
An Object Oriented database is a newer structure that has been
generating a great deal of interest in recent years. It represents very
different approach to the way data is treated by database developers
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and users .groups data items and their associated characteristics,
attributes.
Scope refers to the accessibility of a variable.
There are four types of scopes in C++. They are:
1. Local scope
2. Function scope
3. File scope
4. Class scope
Local scope:
•A
local variable
is
defined
within
a
block.
•The scope of a local variable is the block in which it is defined.
• A local variable cannot be accessed from outside the block of its
declaration.
• Local variables are not known outside their own code block. A block of
code begins and ends with curly braces{ }.
• Local variables exist only while the block of code in which they are
declared is executing
Function scope:
The scope of variables declared within a function is extended to the
function block, and all sub-blocks therein.
File scope:
A variable declared above all blocks and functions (precisely above
main ( ) has the scope of a file.
The scope of a file scope variable is the entire program.The life
time of a file scope variable is the life time of a program.
Example :
# include < iostream.h>
# include <conio.h>
int a = 10; // File scope
void main ( )
{
int b = 20; // Function scope
if ( a > b )
{
int temp; // Local scope
temp = a ;
a=b;
b = temp ;
}
cout << “\n Descending order …” ;
cout << “\n” << a << “\n” <<b;
}
Or Any Valid Example.
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nested if statement :
1)The statement sequence of if or else may contain another if statement
ie., the if .. else statements can be nested within one another as shown
below :
In an nested if .. else statement, “each else matches with the nearest
unmatched preceding if”.
For example:
if (grade = = ‘A’)
if (basic > 5500) incentive = basic * 10/100;
else incentive = basic * 5/100;
else cout << “try to attain Grade A”;
Any 5 Points:
rules for overloading operators:
1)Only existing operators can be overloaded. New operators cannot be
created.
2)The overloaded operator must have at
least one operand of
user defined
type.
3)The basic definition of
an
operator cannot
be replaced
or
in
other words
one cannot
redefine
the
function
of
an
operator. One can give additional
functions to an operator
4)Overloaded operators behave in the same way as the basic operators
in terms of their operands.
5)When
binary
operators are overloaded, the left hand
object must be
an
object
of the relevant class
6)Binary operators overloaded through a member function take one
explicit argument.
OutPut:
HELLO
Values of A and B
The two integers are 10 20
The sum is 30
The multiply is 200
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Find Any 10 Error:
L.NO
1
2
5
9
12
15
17
21 to
22
22
25
26

ERROE-CODE
#include<iostram.h>
include<iostram.h>
Private;
PROTECT;
Class A; public B;
Void func()
int b1:b2:b3
missing

CORRECT-CODE
#include<iostream.h>
#include<iostram.h>
Private:
Protected:
Class A: public B
Void fun()
int b1,b2,b3
}

Void()
Der:a3=0;
A3:fun();

Void main()
Der.a3=0;
A3.fun();

5
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